Función SI en Excel: así es como funciona

Una de las fórmulas de Excel más populares es SI. Su funcionamiento es sencillo: si un valor es verdadero, se desencadena una acción, si no lo es, se desencadena otra. Te explicamos cómo usar esta función de forma correcta y para qué se puede usar.

¿Cuál es la función SI en Excel?

La función SI se utiliza para hacer una comparación lógica: ¿es el valor consultado idéntico al valor esperado o no? Solo si esta consulta es cierta, puede ocurrir un determinado evento. Si la comparación es incorrecta, se desencadena otra acción, es decir, si A, entonces B; en caso contrario, C.

Esto hace de la función SI una de las herramientas más importantes de Excel. La función se puede utilizar en todas las situaciones posibles, ya sea que estés trabajando con un simple directorio de miembros, una hoja de cálculo de las métricas de la empresa o informes estadísticos. La función SI en Excel es útil tanto en solitario como en combinación con otras funciones.

Consejo

Con HiDrive puedes almacenar, editar y compartir tus documentos de Office de forma segura y centralizada. Tanto para uso privado como para uso profesional: trabaja desde la aplicación HiDrive y otras interfaces en el dispositivo que desees con total flexibilidad. Tus datos estarán protegidos en los centros de datos europeos de IONOS.

Excel con Microsoft 365 para empresas y IONOS

Usa Excel para organizar tus datos y ahorrarte tiempo, ¡incluido en cada pack Microsoft 365!

Office Online
OneDrive con 1TB
Asistencia 24/7
Nota

Las indicaciones incluidas en este artículo pueden seguirse en Microsoft 365 y las versiones de Excel 2021, 2019 y 2016.

¿Cómo funciona la función SI en Excel?

En Excel, cada función se basa en una sintaxis determinada, también SI:

=SI(algo es verdadero, hacer algo; de lo contrario, hacer algo diferente)

Por lo tanto, la función contiene tres parámetros, de los cuales los dos primeros deben completarse.

  • Verificación. En este punto ha de presentarse una condición, una comparación entre dos valores, que pueden estar presentes como referencias a celdas (uno de ellos o los dos). Las posibles condiciones son:

  • Igual =

  • Desigual <>

  • Menor a <

  • Mayor a >

  • Más pequeño o igual a <=

  • Más grande o igual a >=

  • Valor_si_verdadero. En este parámetro se introduce lo que debería suceder si la condición verificada es verdadera. Los resultados pueden ser valores, cadenas, referencias de celdas u otras funciones. Debes poner las cadenas entre comillas.

  • Valor_si_falso. El último parámetro es opcional. Si no se especifica nada aquí, la función emitirá FALSO. De lo contrario, el valor valor_si_falso se comporta de forma análoga al valor_si_verdadero.

En la práctica, una función SI en Excel podría tener esta sintaxis:

=SI(A1>=100;"Objetivo alcanzado";"Objetivo no alcanzado")

Consejo

En Excel, las funciones siempre se introducen en la barra de edición precedidas por el signo de igual y los parámetros se colocan entre paréntesis. Si utilizas referencias de celdas, puedes hacerlas absolutas con el símbolo del dólar. Esto hace que las funciones mantengan la referencia a la celda original incluso cuando se copia a otras celdas.

Si no se desea introducir la función SI manualmente, con “Insertar función” Excel ofrece asistencia al usuario a la hora de rellenar correctamente las fórmulas.

La función SI en Excel con un ejemplo

La función SI se utiliza en Excel en una gran variedad de situaciones. La fórmula puede utilizarse tanto en cálculos simples como complejos. En los cinco ejemplos que se presentan a continuación, se ilustra cómo funciona y cómo puede utilizarse.

Ordenar puntos de datos

La función SI de Excel puede ayudarte a dividir puntos de datos basados en un criterio en dos grupos diferentes. Por ejemplo, puede servirte para comprobar si una persona ha aprobado o suspendido un examen. En el siguiente ejemplo, para el aprobado, en el examen debe haberse obtenido al menos el 50 % de los puntos.

=SI(B2 >= 50%; "Aprobado"; "Suspenso")
Puedes usar la función SI de Excel para separar valores en dos grupos a partir de una condición.

Comprobar valores como texto

La función SI de Excel no solo se puede usar con valores numéricos, sino también para comprobar un valor como texto. En el siguiente ejemplo se puede comprobar si Stephen King ha escrito los libros indicados.

=SI(B4 = "Stephen King"; "Sí"; "No")
La función SI de Excel permite comprobar tanto valores numéricos como texto

Anidar la función SI de Excel

En ocasiones, puede ocurrir que, después de haber comprobado una primera condición, se deba comprobar una segunda. En estos casos, también se puede recurrir a la función SI. En el siguiente caso concreto, se comprueba si se ha enviado un paquete.

=SI(B2="Entregado";"Sí";SI(B2="En camino"; "Sí";"No"))
Para poder diferenciar varios valores, se puede anidar la función SI.
Nota

Anidar la función SI es muy práctico, pero tiene sus limitaciones, pues puede resultar en una complejidad que dificulte la creación de sintaxis libre de errores. Para evitarlo, se puede optar por funciones como BUSCAR V o SI.CONJUNTO.

Integrar SI en otras funciones de Excel

Además de anidar la función SI, en Excel esta función también se puede utilizar con otras funciones. Sin embargo, las funciones que se especifiquen como condición de la función SI siempre deben deben producir un resultado que sea interpretable como verdadero o falso. A continuación, se muestra un ejemplo con la función O de Excel.

=SI(O(B2="Entregado";B2="En camino");"Sí";"Falso")
También puede combinar la función SI con otras.

Ejemplo de mayor complejidad

Por último, se presenta un ejemplo algo más complejo. En este ejemplo, se hace un seguimiento del precio de una acción y se indica si este sube o baja con respecto al valor del año anterior. La cifra de subida o bajada también se calcula. Para ello se utiliza la función CONCATENAR de Excel.

=SI(B3<B2;CONCATENAR("Pérdida: "; B2-B3);CONCATENAR("Ganancia: "; B3-B2))
Puedes usar SI para realizar operaciones complejas con múltiples funciones y referencias a celdas.

SI.CONJUNTO: ampliación de SI

Si usas Office 2019, Office 2021 o Microsoft 365, tienes a tu disposición la función SI.CONJUNTO, que funciona de forma similar a SI: a una verificación lógica se le asigna un valor valor_si_verdadero, pero hasta 127 veces. La sintaxis es la siguiente:

= SI.CONJUNTO(algo es True1, valor si True1, algo es True2, valor si True2, algo es True3, valor si True3)

Por ejemplo, podría ofrecerse un descuento en los productos de una tienda si estos llevan un tiempo en stock. Si, además, solo quedan unos pocos ejemplares, se puede incluso reducir aún más el precio final. Es decir, hay dos condiciones: que hayan pasado más de 30 días desde la última venta y que no queden más de 10 ejemplares en stock. Por ello, hay que incluir Y en el primer parámetro de comprobación. Además, se definen más casos, pues se pretende que puedan ser posibles tres resultados: 50 % de descuento, 25 % de descuento y ningún descuento.

En esta función, no hay valor_si_falso, por lo que tendrás que definir la conclusión inversa. En nuestro ejemplo, esta es, el caso en que no se usen descuentos. La regla es:

=SI.CONJUNTO(Y(DIAS(HOY();F2)>30;E2<10);C2*0,5;SI(DIAS(HOY();F2);C2*0,75;C2))

Las dos comprobaciones de descuentos se llevan a cabo una tras otra. Le sigue el caso “si no”: todos los productos cuya última venta fue inferior o igual a la de hace 30 días.

Con la función SI.CONJUNTO, Excel ofrece otras opciones para realizar comparaciones.
Microsoft 365 para empresas con IONOS

Las versiones más actuales de tus aplicaciones favoritas de Office desde cualquier dispositivo. Empieza con nuestro servicio de configuración gratuito.

Exchange con buzón de 50 GB
OneDrive con 1 TB de almacenamiento
Soporte experto 24/7
Page top