La función de Excel SI-O explicada de forma sencilla

Si combinas las funciones SI y O, basta con que una de las condiciones sea verdadera para mostrar un resultado. Te explicamos aquí cómo hacerlo con ejemplos sencillos.

Excel con Microsoft 365 para empresas y IONOS

Usa Excel para organizar tus datos y ahorrarte tiempo, ¡incluido en cada pack Microsoft 365!

  • Office Online
  • OneDrive con 1TB
  • Asistencia 24/7

¿Qué es la función de Excel SI-O?

La función SI-O de Excel es una extensión de la popular función de Excel SI, también conocida como función SI-ENTONCES. Si combinas la función SI con la función O de Excel, tienes la posibilidad de establecer varias condiciones. Para que el resultado sea VERDADERO, al menos una de ellas debe coincidir con el resultado esperado. Si se cumplen las condiciones A o B, se produce el estado C. Si ninguna de las dos condiciones se cumple, aparece el estado D. La fórmula tiene la siguiente estructura:

=SI(O(algo es VERDADERO;algo diferente es VERDADERO);valor si es VERDADERO;valor si es FALSO)

En la fórmula anterior, el elemento “algo es VERDADERO” es la condición A y “algo diferente es VERDADERO” es la condición B. Por consiguiente, el “valor si es VERDADERO” corresponde a la condición C y el “valor si es FALSO”, a la condición D.

Nota

Una alternativa a la función SI-O es la función SI-Y. Con esta fórmula, tanto la condición A como la B deben ser verdaderas para que aparezca el estado C. La función relacionada SI-NO, en cambio, solo acepta una única condición.

Excel SI-O: ejemplo práctico de las funciones combinadas

Este texto contiene indicaciones aplicables a Microsoft 365, así como a las versiones de Word 2021, 2019 y 2016.

En la tabla, la columna A enumera los posibles participantes de un programa de formación. Para inscribirse en el centro educativo, las personas deben haber asistido a un curso básico preliminar o haber aprobado la prueba de acceso con un mínimo de 600 puntos:

Este ejemplo de Excel permite ver cuáles de los participantes han sido admitidos.

Como las condiciones están claras, puedes redactar la fórmula en el siguiente paso. Primero, selecciona la celda D2. En esta, la pregunta sobre la admisión se responde con SÍ o NO. El estado SÍ se produce si un participante ha completado el curso básico (valor “Sí” en la columna B) o si obtuvo más de 600 puntos en la columna C. La respuesta NO aparece si no se cumple ninguna de las dos condiciones. Ahora, introduce la siguiente fórmula en la barra de edición:

=SI(O(B2="Sí";C2>599);"SÍ";"NO")

Después de confirmar la fórmula con la tecla Intro, Excel muestra el resultado en D2:

En la celda D2 aparece la respuesta “NO”, ya que no se cumple ninguna de las dos condiciones.

Para rellenar también las filas 3 a 6 de la columna D con los resultados correspondientes, no hace falta volver a introducir la fórmula. Basta con marcar la celda D2 y arrastrar el marco verde hasta la última celda. Como la fórmula expresa una referencia relativa, B2 y C2 se convierten automáticamente en B3 y C3.

Para rellenar automáticamente las celdas, arrastra el marco verde hasta la última fila.
Consejo

Con el almacenamiento HiDrive de IONOS, puedes almacenar, editar y compartir tus documentos de Office de forma centralizada y segura. Ya sea de forma privada o profesional: trabaja de forma flexible desde cualquier dispositivo con HiDrive. Los datos están protegidos en centros de datos europeos de IONOS.

Combinar la función SI-O

La función SI-O tiene la ventaja de que se puede combinar con otras funciones de gran utilidad, lo que permite realizar otras consultas más complejas. A continuación, aparecen los ejemplos anteriores en una tabla. En este caso, se emplean los nombres y apellidos de los posibles participantes en las columnas A y B:

Tabla con los nombres y apellidos de los participantes y una frase personalizada en la columna E.

En la columna E, no quieres que aparezcan solo las respuestas SÍ o NO, sino la frase completa “[Nombre] [Apellido] ha sido aceptado/a” o “[Nombre] [Apellido] no ha sido aceptado/a”. Para esto, debes integrar la función CONCATENAR en la función SI-O. Selecciona la celda E2, introduce la siguiente fórmula en la barra de edición y arrástrala a las restantes:

=CONCATENAR(A2;" ";B2; " ";SI(O(C2="Sí";D2>599);"ha sido aceptado/a";"no ha sido aceptado/a"))

La primera parte de la fórmula concatena el contenido de las celdas A y B. Para evitar que los elementos del texto se inserten directamente uno al lado del otro en el resultado, inserta un espacio en blanco entre comillas después de A2 y B2. A continuación, introduce la función SI-O, que completa la frase con el resultado correspondiente.

Combinada con la función CONCATENAR, la función SI-O genera frases completas.

La función SI-O de Excel se puede combinar con otras muchas funciones según lo necesites. Sin embargo, asegúrate de poner la cantidad correcta de paréntesis cuando anides las fórmulas, ya que, si no los cierras todos, aparecerá un mensaje de error. Para evitar que se produzcan estos errores, puedes usar el generador de fórmulas del elemento del menú “Insertar función”, que genera automáticamente la sintaxis correcta.

Consejo

¿Te interesa trabajar con Excel? Si es así, puede que te merezca la pena echar un vistazo a los siguientes artículos de la Digital Guide:

Microsoft 365 para empresas con IONOS

Las versiones más actuales de tus aplicaciones favoritas de Office desde cualquier dispositivo. Empieza con nuestro servicio de configuración gratuito.

  • Exchange con buzón de 50 GB
  • OneDrive con 1 TB de almacenamiento
  • Soporte experto 24/7
Page top