Joomla!: Actualizar la versión de PHP

Le explicamos cómo cambiar la versión de PHP que ejecuta en su sitio web de Joomla! y qué considerar al cambiar a una versión más nueva de PHP.

¿Qué es PHP?

PHP es un lenguaje de programación que se ejecuta en el servidor web. PHP se utiliza principalmente para crear sitios web dinámicos o aplicaciones web. Todos los sitios web de Joomla! funcionan con PHP.

¿Cuándo se debe cambiar la versión?

Al igual que Joomla!, PHP está siendo constantemente desarrollado y optimizado. En los siguientes casos, por ejemplo, se requiere que los operadores de un sitio web de Joomla! cambien la versión de PHP:

  • Una actualización de Joomla! requiere una nueva versión de PHP.
  • La versión de PHP que está usando es obsoleta y no debería ser usada más.
  • Una nueva versión de PHP está disponible e incluye mejoras de rendimiento de las que desea beneficiarse.

¿Qué versión debo usar?

En IONOS puede elegir entre diferentes versiones de PHP. En regla general, recomendamos usar la versión de PHP más actual. Actualmente es PHP 7.3. Con esta versión se pueden utilizar las aplicaciones más populares y probadas sin más problemas de compatibilidad.

Cambiar la versión de PHP

En pocos clics puede actualizar la versión de PHP para su dominio y por lo tanto de su sitio web.

Sin embargo, es posible que la versión de Joomla! utilizada, los plugins individuales o el tema no sean totalmente compatibles con la nueva versión de PHP. Para evitar cualquier malfuncionamiento, es aconsejable preparar el sitio web para el cambio de la versión de PHP y, a continuación, cambiar la versión PHP.

Recomendamos el siguiente procedimiento para preparar y realizar el cambio a una nueva versión de PHP:

    • Crear una copia de seguridad

      Antes de cambiar la versión PHP, debe hacer una copia de seguridad de su sitio web Joomla!. Le recomendamos el plugin gratuito Akeeba Backup. Akeeba Backup es una solución de copia de seguridad de código abierto fácil de usar que le permite crear una copia de seguridad completa de su sitio web.

    • Actualizar la instalación de Joomla!

      Cuanto más antigua sea su versión de Joomla!, más probable es que el código de programa PHP utilizado ya no sea compatible con la nueva versión de PHP. Por favor, compruebe si las actualizaciones para su versión de Joomla!, plugins y el tema están disponibles. A menos que necesite usar una versión más antigua por alguna razón, siempre debe mantener su instalación de Joomla! y todos los componentes actualizados porque estas actualizaciones también cierran regularmente las brechas de seguridad.

    • Comprobar la compatibilidad del tema y el plugin

      Si está utilizando plugins de terceros, como un álbum de fotos, puede comprobar de antemano si es compatible con la futura versión de PHP. Abra la página extensions.joomla.org y busque los plugins correspondientes. En la página, haga clic en el botón Support. Busque en el contenido de la página consejos sobre la versión de PHP. Puede que esta información se encuentre bajo otro enlace, p. ej. "Requirements".
    • Cambiar la versión de PHP

      Después de haber preparado el dominio, puede actualizarlo a la versión deseada de PHP. La activación de la nueva versión de PHP sólo tarda unos minutos. Más información: Ver o cambiar la versión de PHP

    • Comprobar si hay errores en el sitio web

      Tan pronto como la nueva versión de PHP esté activa, debería revisar inmediatamente el sitio web a fondo:

      • ¿Es accesible el sitio web?
      • ¿Son todas las subpáginas accesibles?
      • ¿Funcionan todos los elementos, galerías de imágenes, formularios etc.?
      • ¿Funciona el backend (área de administración)?

    Nota

    Si ocurren problemas al usar la nueva versión de PHP, se recomienda comprobar todos los plugins de nuevo por su actualidad y compatibilidad. Es posible que tenga que desinstalar o reemplazar plug-ins incompatibles.

    Para restaurar la disponibilidad del sitio web y/o del backend lo más rápidamente posible en caso de problemas, puede volver a cambiar el dominio a la versión anterior de PHP. Tenga en cuenta que puede tardar unos minutos después de haber realizado el cambio para que esta versión de PHP vuelva a estar activa. Si también se producen errores con la versión antigua, tendrá que restaurar su sitio web desde la copia de seguridad.